Bugged erc-721 contract, can't update metadata

Hi, I am trying to change metadata at one of my 1/1 artworks on a specific erc-721 contract. I am super confused by the new Manifold studio.

I have searched around and tested multiple ways how to do it. I even found out that I am very easily able to change metadata of artworks on other erc-721 contracts of mine, but this one seems to be glitched somehow.

I am also not able to “publish changes” on the artwork. I tried that because I thought it might give me option to update the metadata. None of the tokens minted on this contract can be edited.

Can you take a look please, thank you
0xe6de9efb8097c1bc694cd6edf00d9cafc084867a

gm - Can you share the contract/token you’re looking to edit the metadata for? What error do you see? Where are you stuck? We’ll need a screenshot of the error along with the console. Instructions here:

Hello,

sure. So I want to update the media file on this artwork, the contract address where this artwork is minted at is 0xe6de9efb8097c1bc694cd6edf00d9cafc084867a, I am trying to change metadata on the artwork #6, but I have tried (just in case) on more of them and the issue is everywhere the same.

What I am trying to do is this:

  1. On the Home page in the studio, I find the artwork.
  2. I get on the page of the artwork and it the top left I go from the summary tab to the edit tab
  3. Here I am expecting to be able to change the metadata, name or the media of the artwork (here it is important for me to add that this works for my other contracts, both erc-721 and erc-1155)
  4. However I don’t see the settings for changing the metadata, instead of that I am seeing the this (screenshot)

And here is the console screenshot alongside this page

I tried clearing the console and do everything but the problem persists

I think the biggest problem is that this doesn’t seem like a bug, but it is basically unallowing me to change the artwork which I used to do for the whole last year on this specific 1/1.
Also this page is very different to my other tokens that I am able to edit on this page.

When I go to the bottom right corner of this page, I see publish button. I tried to publish just in case it solved the problem, which gets me here:

image

System details:
Browser: Brave 1.65.132
Metamask used
MacOS macbook pro


I am also having an issue seeing all of my minted artworks on the home page, and I have to browse for them to the inventory, where it is much harder to get on the edit tab since clicking on them from the inventory page immediately redirects me to the public Manifold Gallery page.

Is there something I can do with this issue as well? I am quite struggling with understanding this new UI.

Thank you so much for the quick response, I appreciate it.

Hi, what you clicked on is your gallery listing, not the token itself. It looks like the token was created via address:
0xcf04f8b64123ee5134b6d0db1473c78ea1d74822

And is located under that account. Do you still have access to that address? If you login with it, you should see the token (by filtering for 1of1’s)

Hi,

This is weird. So firstly yes, this is my address, but a very old one that I literally stopped using a year before minting this token we are talking about.

this is the transaction that minted the artwork:
0x705eb746c9ef6b780372ea8fa9baa8d765744de798469e06b5fd2aae383fc151

On the link it shows that the minter was my wallet 0x151E86b0F89Ed7940231b6f198e1656664b8CFE9, so I don’t believe I have misplaced my own wallets here, especially when the first one has been closed and ditched a year before this token came into existence. Also I have been doing all the metadata updates on this token so far from this wallet 0x151E86b0F89Ed7940231b6f198e1656664b8CFE9 (the seller one).

In the past year I have done about 9 or 10 metadata updates on this artwork already, and for all that time I have used the main wallet ending with CFE9. All my art contracts and artworks has always been made by this wallet and I have always managed all of it within your old studio from this wallet.

Only just in case and to be sure I have tried logging in into your studio the wallet you gave me, ending with 4822. I had to import it again into a new browser. Upon logging in, your page wanted me to enter my email, which I did.
Then I got this email

So it seems like this email is already active on another wallet (the currently used CFE9 one). There is 0 chance I have been going through this before regarding the metadata updates.

Can you review this once again please?
I really don’t understand this because it used to work with the old UI and after this update I am suddenly unable to change metadata on 1/1s only on this contract. Which is by the way in the list of my contracts under the CFE9 wallet, sending screenshot below as a proof. The problematic contract is the Bastien second from the bottom

So the wallet I am 100% confident is the right one and also is the creator (by ethscan) of this artwork: ending with CFE9
The one I haven’t been using for two and you sent me: ending with 4822

Thank you for helping me with this.

Ok let me edit here a bit. I recreated an account on the old address using another email, and some of the artworks really are there.

I will number the questions

  1. Could you please explain to me how is this possible? Is there anyway how I can add another administrator on the currently used wallet to these so I don’t have to log into this wallet everytime I need to do anything?

  2. Is there a way how I can consolidate these two accounts under the new wallet? The way I used to have it in the old UI?

  3. How is it possible that in the old UI I used to do these things together within just one account and now this issue has appeared?

  4. Also pardon me for so many questions, but when I am able to see the artworks minted on the 4822 wallet, why the contracts they are minted on are seen as being owned by the CFE9 and not in the 4822 at all? This is so confusing, I am sending a screenshot of the other account…

So inventory says no tokens, but home page shows about 8 tokens (those that are missing from the other account)

Hey there,

So, I’ve added your old ‘workspace’ created by the old address to your new address. So now, if you refresh the page, you’ll see the both workspaces on the account you logged in with using ‘0x151E86b0F89Ed7940231b6f198e1656664b8CFE9’ and your old tokens can be managed there.

Sorry for the confusion, we’re still building out the ‘Workspace’ feature at this time, but to answer your questions:

  1. what happened/how this is possible: during the migration, anything created with your old wallet was migrated to its own account and Workspace.
  2. is there any way to consolidate: I’ve added you to your old account’s workspace, so you should be able to see those assets now. Migration of contracts and assets from one workspace to another is in the works (consolidation)
  3. how did it work in the old UI: In the past, whenever you added an on-chain admin to any existing contract, it would ‘automatically’ add and approve you to the content created by that contract’s workspace. We removed this feature because it was a security hole (in that, anyone could add a contract to your account without your permission).

We’re moving to an explicit permission based Workspace model so that this type of ‘Contract Injection’ isn’t possible.

Please let us know if. you have any further questions.