Burn issue on Manifold studio

I’m trying to set up my burn token but manifold studio is not picking up the contracts and token already minted. I have 3 contracts set up but it’s not picking up any of them? I can’t select the desired burn token. How can I fix this?

You can always use “other contracts” and enter the contract address and token ids manually.

Can you share the contracts of the tokens you’re trying to burn? The “your contracts” section only shows manifold contracts.


This contract was made on Manifold so it should show up but it’s not for some reason

Does it show on your Home Screen? If not you might be logged on as the wrong account.

So I can see the contracts under my wallet acc but I can’t see it when I click the Burn redeem App. I did tried switching between wallets and it didn’t make a difference. Is there anything else I should try?

Will take a look. What address are you logged in as?

I looked into your account. It seems like you used other addresses to deploy these contracts rather than your main account login address.

To have the contracts picked up, please go to your settings page and add the deployer addresses as linked addresses.

I updated this for you and this should be addressed now.

thank you so much for fixing this. It works now.