Burn not working ‘Not allowed'

There’s currently a burn edition going on, and one of my collectors can not burn his tokens.
There is also a “Not allowed” text on the burn site above the Burn & Redeem button.
Any idea what this is and how to fix it?

thanks in advance

Looks like your collector was on mobile. Were they using WalletConnect or MetaMask Mobile? It looks like MM Mobile to me.

In the meantime if they have access to a desktop browser, that will for sure solve their problems while we investigate what the issue is with the setup they were originally using on mobile. Debugging as we speak.

Also please provide a link to the burn if you can, thanks!

Should be fixed now!

Hey johnny!
Here’s the link to the burn: The Lab - Dopamine
The collector is using Trust wallet and also tried it on desktop.
He just told me “I tried and it seems like it’s trying to work now but won’t complete strangely.”

Thanks a lot for your help!

Just pushed out one more patch, ask em to try one more time after a fresh reload of the page! Thank you for the patience lorem.