Burning a contract on mainnet

Looking for a way to burn a contract that holds no tokens.
When “revoking ownership” in etherscan the gas is over $1K, is there any other way? any help would be greatly appreciated


Unfortunately there is now way to delete a contract once it’s live on mainnet. You could alternatively transfer the ownership to the burn address: Transferring Ownership - Manifold Docs

1 Like

I realized I accidentally transferred ownership to the actual contract address. Does manifold have access to the contract address?


Hi @aguspunk I have a contract that I made a while ago with one wallet and I want to transfer it to another wallet. If I try it via Etherscan it says gas is like $700 because they can’t estimate it. What would normally be the price to transfer the contract?

The strange thing is that it does show I am the contract creator (marieke.eth), but when I want to change things I need another wallet?? so something is off

can you take a look and advice what’s the best solution for making sure this contract is connected to thecorrect wallet?

This is the contract address and I really like to keep that contract;


Something is really weird with this, both Rinkeby and main net show the correct wallet as the owner of the contract, but when I try to mint the first token, Studio is asking met to deploy to Goerli with an old wallet. So it seems to be something to do with Studio?

What should I do, I am about to mint a token

Scherm­afbeelding 2022-12-08 om 20.13.18

Transferred ownership of a contract to the burn address, but it’s still appearing in my Manifold Overview panel. Is there any way to force a sync on my profile so it no longer displays?

Hi - I also deployed a contract on mainnet and I am trying to delete it and found that I could transfer ownership to another wallet. Please share the most up-to-date information on how to do this. It didn’t work when I connected my wallet to etherscan, it said that the contract didn’t allow for permissions to change ownership. There was no “transferOwnership” function under “Write as proxy” can you please HELP! Any suggestions of how to fix this please help.

Hi - I just tried doing the transfer of ownership of my messed up contract and when I connect my wallet to etherscan and went to the “write as proxy tab,” there was no button for “transfer ownership.” And when I tried another thing it said that my contract didn’t allow for permissions to do anything. PLEASE HELP!