Burning a token

I can´t delete a token. when I try to burn it, I have problems in Metamask. It says, It can´t estimate gas, It may be an error in the contract.

You can only burn a token that you own. What is your address and the link to the token?

thank you
yes I own it

Mainnet address:0x518b18e4a0ee8360a5a820dd22f8bedc6f62ce56

and this is the token

I can’t see your studio info. What’s the contract address and tokenId? Are you trying to burn through the UI or through etherscan?

this is the contract
and the token ID

I tried burning through etherscan

The owner of that token is 0xcDA72070E455bb31C7690a170224Ce43623d0B6f

Are you connected as this wallet? I just tried a simulation and it seems fine. If you’re having problems, please send a full screenshot of the etherscan page showing your inputs, contract address and the connected wallet.

That is not my wallet ( 0xcDA72070E455bb31C7690a170224Ce43623d0B6f)

my wallet is: 0x13660A11544719c8F31eb12473c9153c916F236f
and here it is the toke, it wasn´t sold Dana Fanego | Foundation

The reason you can’t burn is because Foundation currently holds your token. You won’t be able to burn until you cancel the sale on Foundation.

Thank you so much! It was that, now I could finally burn it