Can not connect to Manifold Studio

I can not connect to Manifold Studio and have tried for days. The manifold website comes up fine but when I go to Manifold Studio I login with my Meta Mask and it just spins. It says in my Meta Mask that I am connected. I use Brave browser and have even turned off my shields and VPN but it still will not connect. My other friends are not having any problems. I don’t know what to do here. Help!

1 Like

Can you please share screenshots and your browser console logs?

If you open up brave do you see a pending signature request? If so that’s probably what’s getting you stuck.

Also please try clearing your browser cache and cookies.

I have done that. There is no pending signature request.

A but confused. Are you using brave with metamask or the brave wallet. Can you take a screenshot of your screen where it gets stuck?

Is this what you see?

Make sure you also unhide the tab icon for metamask and see if there’s an alert notification.

If it’s not working, please share your console logs:

Also, have you tried Chrome rather than Brave? It’s possible Brave’s wallet is intercepting the requests if it’s been set up. Any notifications in the Brave Wallet?

I am using Brave browser not Brave wallet. I have all Brave browser shields down so there is no messages from them. I have always used Brave and do not ever use Chrome. I have no wallets set up with Chrome. It just spins and doesn’t connect.

I redid the clearing of everything again anf I finally got to the page you showed me. I am logged in to manifold studio but it is still asking me to login. When I try again it does not give me the metamask option. You mentioned make sure metamask is not hidden. How would it be hidden and how do I unhide it. Also I am working on a desktop and not a phone. The phone option comes up but the desktop option is not. So I tried to do it with wallet connect and it is still wanting me to use my phone. It says or through your metamask wallet which I did.

But clearly you can see that I am logged in. What am I doing wrong??

Why doesn’t the metamask wallet come up like it did in your picture? I connected it through my metamask like it said I could but still cant get in.

Thanks for providing screenshots. We will investigate and get back to you, sorry for the frustrating experience.

Could you try updating your metamask and your browser please? You can do so by going to the “setting” section on the top right, and choose “Extension”, you can then choose your metamask extension to update

Actually before you do the update, do you mind right clicking on the screen, choose “Inspect”, then click on “console” on the top right. Try to log in again, there should be a few errors that show up under “console”. Do you mind copying and pasting it here please?

From your screenshot, it looks like you are using Phantom Wallet as well. We have seen issues in the past when you have both Phantom and Metamask wallet installed. Do you mind disabling one or the other, and refresh the page please?

You mean totally remove my phantom wallet? I also have a Xverse wallet. It took a lot to set them up. They are just other extentions. Why would they have anything to do with signing in with my metamask wallet. I had Phantom before I was on Manifold. I dont understand why it wont come up.

I disabled the Phantom wallet and it worked. That is strange that one has nothing to do with the other. I would have guessed the new Xverse wallet because I just added it.

We can also try to update your wallet extensions and see if it still work if you have all extensions enabled. Do you mind doing the following steps to update your extensions please?

  1. On the top right corner, there should be an icon with three horizontal lines, click on it and select “Settings”
  2. Click on “Extensions”
  3. Click on “Manage Extensions”
  4. On the top right, turn on “developer mode”
  5. On the top left, click on “Update”

This will update all your extensions

Yes, they are all updated

Thank you for all your help! Now what is this that just popped up on top? Do I need to do this also? I have deployed ETH contracts and My email and twitter are linked.