CSV files is saving as tabs instead of comma's in EU version of excel

Hi, trying to create a csv file with wallet addresses, but my csv file in excel saves it as tabs, Anyone else had this problem and how did you fix it?

This is what I have done sofar;

  • changed the settings in excel under data, but if I select comma as seperator, it creates a tab instead
  • search and replace tab for comma, but when I save it a csv it again creates tabs
  • changed Excel to English US version
  • changed my Mac system to US

still not saving the csv files with comma’s so I keep getting the message screenshotted

This is driving me insane…