Data Sync Issue + Error Saving & Publishing: Missing published data

Hi, trying to update the token artwork on an existing contract. Getting the following error:

A blue error box saying ‘Data Sync Issue’ saying i have unpublished changes and prompting me to publish updates. But when i hit publish i get a red error message saying 'Error Saving & Publishing. Missing published data for instance. Is instance published? ’

screengrab showing both error messages

Ok i just accidentaly recreated the error on a different token/contract and i know how its triggered! - i updated the artwork, went to publish but then cancelled the transaction in my wallet. This seems to have triggered the bug (i also remember i did this on the first token)

The token seemed fine after i cancelled the trasncation, i clicked back to home but then went back into the token edit section and immediately the Data Sync Error message was visible, and again the same red Publishing Error message popped up after trying to publish.

Hope this helps to debug.

Ps i have previously tried using the metadata update to see if that helps and it doesnt.

Yes, if you cancel the transaction it’s going to tell you that your data is out of sync. It’s basically warning you have unpublished changes (since the act of hitting publish saves it to our side).

so whats the fix? because it becomes stuck at this point and wont let me actually do anything. the wallet popup doesnt open, it wont connect to Metamask.

Are you trying to actually change the image/animation? If so, uploading/changing it and hitting publish should bring up the dialog to submit the transaction.

Also please clear your cache.

1 Like

yes trying to change the image, but thats exactly what im telling you - after i change the image and try to publish is when i get the bug

Can you try logging out, clearing your browser cache, going into the page for edit and trying once more? We pushed an update and your browser may not have picked it up.

Also, when you go into the edit page, you should not see a warning initially. Can you confirm this is the case?

Ok i think clearing cache worked this time! I tried clearing and restarting yesterday but turns out only ‘images’ were set to clear. I changed it to clear all data and its let me go through with the transcation, just waiting for ti to finish processing

When i first go to eh edit page the Blue warning about Data Syn Error was still there. But after publishing it went through and no other error popups this time.

Great, glad to hear it.

1 Like