Error deploying contract

Hi, I’m trying to deploy a claim page but it keeps getting stuck when I try and publish.

Awaiting execution (2/4)Please review contract transaction
An unknown error occured. Please contact support by clicking on your profile on the top right corner.

Could you please advise?

Wallet (Metamask): 0x2AeCF9c222eA50Ec4006abAa3f60bD92A2a2553d

Chrome browser.

Thanks in advance,

gm! Can you take a screenshot of your console? Do you see anything popup from metamask?

gm Lyndo

Nothing happening from metamask

Have refreshed and tried many times

Can you take a screenshot with your console showing? Should look something like this(Instructions in the link above):

1 Like

Ah ok, got it:

Looks like some plugin on your browser is blocking one of the calls needed to deploy a contract.

Do you have any other plugins or wallets installed other than metamask?

Do you have coinbase wallet plugin installed?

Ok, this is a known issue if you have both coinbase wallet and metamask installed. Temporarily disable coinbase wallet and the issue should go away.

We’ve reached out to the coinbase team about this

1 Like

This worked! Thanks so much for your help :slight_smile:

No problem. Coinbase has confirmed they’re rolling out a fix in June 17th.

I have the same issue but do not have coinbase wallet.
I have been able to use the contracts in the past.

Have you tried:

  1. Disabling Coinbase extension if you have it
  2. Restarting your computer (not just the browser). Sometimes metamask gets into a bad state that can’t be resolved without a computer restart.