Frame Mint on Base App - Ability to not require recast/Custom mint button text

This is awesome and amazing…! Priority feature request would be:

  • Ability to NOT require Recast—and ability to enter Mint button text as desired
1 Like

gm! Appreciate the feedback!! Let us know if there’s any other functionality you’re hoping for here

Yeah, this is amazing work… well, in this case of minting a token, certainly the ability of limiting the supply and duration of the minting availability (I see that the Frame URL expires in 24 hours currently.) (Or, to increase both, for that matter, as well…)

1 Like

Just noticed that on the Frame URL page, that URL (in the window) is correct, in the form, and if copied into Warpcast composer window, it renders the frame; but if you instead click the “CAST TO MINT” button, the URL it populates to the Warpcast composer window is in the form, which doesn’t render the frame
…at least in the window I’m looking at.

1 Like

Also, certainly the ability to edit all aspects of the token (as is typical in Manifold Studio), particularly to correct errors…

1 Like

Thanks for all the feedback dude, super notes. The URL typo has also been fixed!


My pleasure, love Manifold…!

So, I’ve just tried another Frame, this time choosing the new “Like” to mint option, and posted it on Warpcast… and I did look at it in Frame Validator and it seemed fine…

…however, after posting it and trying myself, I could not get the mint to work. It kept returning screen “Like to mint, try again” something like that; I tried numerous times, clearing cache/hard reload, with no luck… I finally deleted the Cast.

Earlier, I had started to notice some Manifold hosted frames being posted, with “Follow, and click Mint” which I realized was new, and tried a few of them… there was definitely some glitchiness, some I could get to mint after several tries, some not… with my own Like to Mint just now, I could not get it to work…

I also, just now, did another Frame, this time back to the “Recast and click to Mint” option… and posted that on Warpcast… and could not not get that one to work either, so deleted again.

I suspect this could well be a problem on my end, but don’t know how to tell… but I just disconnected, logged out, re-logged back in, and re-connected, tried again and still no luck. Also, despite the fact that I deleted the casts, they were “liked” and “recasted” a couple times, before I did… but I don’t see any minting transactions from either one on BaseScan, leading me to believe that those users also couldn’t mint…

P.S., I just tried someone else’s “Recast to Mint” on desktop, and then on mobile, could not get it to work on either…

1 Like

Yeah, unfortunately… while having the options are great, it seems like having the forced prerequisite of either to like, follow, or recast, to be able to mint, is getting some negative traction on Farcaster