Having issues logging in to studio with metamask (Using Phantom and Metamask)

I’ve been trying to log in to creator studio for the last 2 days.
After the launch studio wallet options , I chose Metamask and it just says “logging in” forever.
I’m on chrome have tried clearing cache restarting the browser restarting my laptop …

Thanks for reaching out - Can you provide a bit more information? - Do you have other wallets installed? Are you able to connect on any other services?

Can you take a screenshot of your console? Instructions here:

As far as eth wallet goes, Phantom is the only other one that uses the Eth mainnet network…
Don’t have issues logging into any other sites except maybe foundation on which I have to use other wallet instead of the metamask option to log in…

A few things that can cause this to happen:

  1. There’s a pending signature request on one of your wallets. Sometimes metamask doesn’t pop up asking you to sign in. Can you double check that? (I’m assuming you’re choosing metamask)?
  2. Can you try restarting your computer (not just the browser). Sounds funny, but metamask sometimes gets into a really bad state where a computer restart is needed.

I have tried both! cleared cash restarted browser and restarted my computer.

That’s very odd. After you click login, can you detail or screenshot every step you see? There should be a popup asking you to sign a message. Do you get that?

I get a pop up by phantom asking which extension between it and metamask i want to use. This is before trying to log in. When I click the log in button there is a drop down menu for the extension and when choosing metamask nothing happens…

Did you just install phantom wallet? Have you tried disabling it? just want to isolate the issue.

Ok, I was able to reproduce the issue. It is in fact an issue with Phantom wallet + metamask.

We’ll look into it, but I was able to bypass it by refreshing studio.manifold.xyz a few times. Once phantom asks you to use metamask TWICE, it should work.

It should also work if you choose metamask and also checkmark ‘don’t ask me again’

Hi, are you able to login now?

Hi! Yes it worked!
I got it to work by porting my wallet to brave first but then tried the “don’t ask me again” trick and it also worked! Thank you very much for your help!