Hello, I cannot load the Claim Page. It remains blank. Help me!

I have read about problems just like this one I have but have not been able to solve it. I don’t know what I need to have (if anything) to use Claim Page. I have had my account verified for some time, everything seems to be working fine. Help !!!

gm! Sorry to hear that you’re having issues - Can you send us a link to the claim page? It usually takes a few minutes to populate

I too am having issues with the claim page. The image on the claim page does not show.

1 Like

Hi , of course Manifold Studio

it stays like this. for 2 seconds it shows the charging signal and then it goes blank like this…



The image is not loading and shows as a broken link to the image.
Could you help me?

Thanks for reporting - We’re investigating the issue

Thank you so much. Im not sure what I need to do to make it work.
I tried to get it resolve before reaching out, but its been a few hours and I can not seem to get it fixed. I tried several things and even asked frens that are use to the platform and they can’t seem to help.

It worked :hugs::raised_hands:t2: Thank you. Thank you. Thank You!!

Awesome! Issue should be resolved now

1 Like

I am soo grateful!!!

gm mine is still unresolved.Thank you very much for your response.

Ah got it - This is loading the claim app itself. You’ve tried disconnecting and reconnecting again? What browser are you using?