Help needed with weird MetaMask wallet block due to Manifold transactions... weird I know

Hello all,

I am not a dev, but I am looking for a manifold dev to help out. So here is the issue:

Jan 7th (Korea time) I was trying to mint some pieces to enter into the Optimism We Love Art Contest. The interactions were lagging, I waited a while, nothing happened, closed and tried 2 more times. Total tries are 3. First 2 went no where, last one went through because I came here and saw that others had issues too that day so I figured it was a bug that needed fixing or congestion for the contest that needed to figure itself out. Third try is the charm, all goes very well.

I was able to use my wallet normally after those interactions, no issues. Figured all is good and minted a few things, you can even see interactions on the optimistic scanner after the contract was created and the pieces minted with no issues.

Then yesterday (11th) I was trying to mint a Nomo Noun and boom, its not working. Then I realized that even the day before that (the 10th) I was not able to mint a Nomo even though it said it went through… So last successful use of the wallet was 2 days after the errors from Manifold for creating a contract.

Spent a good 30 mins or so with MetaMask customer support doing all the things they had told me to do which is namely an account reset. I also downloaded Rainbow and entered my seed phrase, tried using the wallet there and it is still inoperable. Cannot even send 0 ETH to myself!

The error I get the most on metamask is the “Internal JSON-RPC error” which upon googling says to disconnect and reconnect metamask to the network causing the issue so I did that multiple times - Disconnected and reconnected to Optimism.

So why am I here and not on a metamask forum? Because the Metamask team is INSISTING it is a stuck transaction in the “collection contract creation” contract I interacted with on Manifold. Even though I do not see how so since there is no transaction on chain about it…

I have screenshots of the errors and here they are:

Transactions #10 & #11 shown here are the ones that got stuck on manifold and the ones I mentioned above as the 2 initial tries that did not go through on the 7th. Those are the ones that MetaMask support is insisting is the cause of the issue and still stuck somewhere in the contracts even though they do not show up on the explorer… time stamps are in Korean time (as I am on vacay here at the time this happened)

After reseting I tried to send 0 ETH to myself. Failed 2ce:

I get the same error as before I reset about some “Internal JSON-RPC error” that I could not resolve with internet searches of what to do in this situation (to be clear, this error comes before and after I reset my account in the advanced settings of MetaMask):

Before I tried to reset, I got those asking to up the GWEI, so I transferred enough to do so, so ETH comes into the wallet BUT CANNOT MOVE IT OUT and it is not working with this either… This did not help me “Speed up” or “Cancel” the faulty transactions.

After reseting the account the faulty transactions no longer appear in my list on MetaMask transactions tab:

Rainbow won’t work on desktop or mobile:

When I clicked on the faulty transactions in my transactions list on metamask this is what I saw. NOTHING on the explorer (ARGGGGHHH)

This is another weird thing it asked me to do, pay 0.46 ETH to make the transaction either move faster or cancel it… I did not do that (eye roll).

As you see, my Optimism network settings are standard and should work ok…

gm Chadi!

Sorry to hear about all your frustrations here. I see you’ve been able to do a number of transactions since last night. Are you still having issues?

Please let us know!