I can not upload Batches

I am gucci1952.
I can no longer upload batches to the test network.
Before that, here is what I did
I tried to delete a token uploaded in a batch to the test network by clicking on “Delete Token” in the menu of the batch window displayed in the Tokens tab.
However, the tokens were not deleted and the batch changed to a single display on the Token tab page.
I then deleted the tokens in the single view one by one.
Next, I tried to rename the contract and upload a new batch by clicking “Create” and then “Batch of Tokens”, but the upload screen did not appear and I was returned to the “Create” screen. However, if it is a ‘Single Token’, the upload screen will be displayed.
Furthermore, the same result was obtained when a new contract was created.
Please let me know if there is a way to recover.

Aware of an issue with batch minting. We’re looking into it.

Hi gucci,

Thank you for bringing this to our attention. The issue has been fixed. Please try again and let us know if it is working for you.

Thank you.

Now it’s working.
Thank you.