I cant switch to the Goerli test network

I am trying to set up a new contract on the test Network. I have tried two machines and still can’t move from the mainnet to test any ideas. is there a coinbase issue with manifold?

gm! I’m a little confused where you’re stuck, this is on the contract deploy screen? Can you take a screenshot?

I can’t switch from mainnet anywhere in manifold. I’m having to work in my coinbase browser which isn’t easy.

If you scroll to the top, do you see this icon?

clicking on “Mainnet” will show a dropdown which let you switch network

Yes, I know that but it’s not working. when I click it doesn’t move. It seems to be locked on mainnet…

Also, I’m getting this too

For switching network, is that still an issue? If yes, can you please right-click on screen, then click inspect and screenshot what is on “console” tab, when you try to switch network?

For not admin of contract address, please make sure you log-in with the right wallet address.

is this what you want? if not please provide more detail about the ‘Console’ tab I use Brave. I only use one wallet so the wallet address is correct.

Click on the Console tab in the red circle, and then try to switch network. If there any errors, you can screenshot. Moreover, please give me the contract address that you have problem with. Thank you so much!

this is the current contract but I can’t switch to Goerli anywhere in my manifold account.
I have had to use the browser in my Coinbase wallet to test-mint everything in this new contract. I haven’t used Manifold for a while before this week.

New York 1981

Mainnet Logo







Mainnet address:0x636468282a449d4cd86b82f23be21afa9db7f9be

Goerli address:0x74ddc6d585f6ab4e4939d14de247546ce9f21228

On your browser, are you using Metamask, Coinbase Wallet or WalletConnect?

I use Coinbase wallet I use Coinbase wallet

We suspect there are some issues with Coinbase Wallet extension on browser. We are trying our best to fix it on our side. In the meantime, you can use Coinbase Wallet Mobile App Browser and connect with Manifold Studio (we have tested and it works just fine).

You just need to switch to Goerli to do anything with this contract 0x74ddc6d585f6ab4e4939d14de247546ce9f21228 , as it is on Goerli testnet.

I thought so… And yes that’s how I have been working around the issue.

Hey guys,

Having the same issues here as well and the workaround through Coinbase Browser is also not working.

Have tried through wallet connect with Zerion, Rainbow and CB, getting the same issue, unable to switch networks whatsoever.

Anything else you suggest to try? Just trying to deploy a new contract to Optimism atm.


I think possibly it’s also a Coinbase issue I’m having issues with it on other platforms it’s running incredibly slow. I have to login in the app browser before attempting to login on any site like foundation knownOrigin and Opensea

Hi, coinbase wallet network switching should be fixed now, can you please try again?

That’s now working. Thanks, everyone.