I deployed my contract on mainnet but manifold says I didnt

Hello, I have just deployed a contract to the main net. I deployed on goerli and it works fine. I payed gas to have it deployed to the main net. The transaction went through but manifold says it didnt. On etherscan I see that I have deployed the contract but theres nothing in the contract. When you look on goerli etherscan the full contract is there. When I try to deploy it again through manifold it says something went wrong. Can anyone help?

Wallet Used: 0x420B430CB40658c03F079f145ED2969CcaAA2947

Same! Right now.

But for me it even gives me problems in Goerli (the platform tells me that it will let me know when it can…). I passed on that and tried it directly on Ethereum, and the same thing. I hope I didn’t lose my gas.

Is this resolved now?

Can you share the transaction and a screenshot of what you see?

It was solved. After about half an hour I received an email that the contract was deployed and I verified that it was ok.

There must have been saturation or something, but everything was ok. Thanks! :pray: