Incorrect implementation of Connect Button on

Hi, we’re currently beta testing our new browser extension wallet at Bitski and we’re running into issues connecting with Manifold. By default, it looks like Manifold will call eth_accounts to attempt to connect to the injected wallet. It will then attempt to call eth_requestAccounts if no accounts are returned, but ONLY if the wallet is MetaMask, Coinbase, or Ledger:

In order for our wallet to work, the Dapp needs to connect via eth_requestAccounts or eth_requestPermissions, which is the standard. So, we currently have to impersonate MetaMask to get Manifold to trigger the correct behavior. This is not ideal because it means that our wallet cannot work seamlessly side by side with MetaMask for users who use both.

What’s the best way to address this in a way that works well for all wallets in the ecosystem?

Hi. What flag will be on your injected provider. Typically people will flag it with some identifier (like isMetaMask, etc.)

We flag it with isBitski normally, when not impersonating MetaMask

We’ll get this out with our next release.

New connect widget supports bitski!