Issues deploying first creator contract

Hey! I have a problem deploying my first smart contract. I have never used Manifold before and I’m about to create my first contract on it but it doesn’t seem to be working for me. Looks like a website error. When I click on create a contract it directs me to Home page and it doesnt let me scroll past this phrase “Ready for your first contract” cuz that’s where I assume there should be a button or smth to click and go to the contract page. Would deeply appreciate any help.

Can you take a screenshot of where you’re stuck? What browser/device are you using?

Thanks for getting back to me. It’s a browser issue I think, I use chrome on PC. I tried on a MacBook / chrome and it worked.

I also tried to deploy a contract, it went through Metamask, but in the manifold is stuck, not sure what to. do.

Hi MadMaraca, it seems like your contract is properly deployed. You should be able to see it when you login to studio.

If you don’t see it, or this is the wrong one, can you please share a screenshot of what you’re seeing?

Hi atarpanov, it appears your contract is properly deployed:

If you’re still having issues, please share a screenshot of where you’re stuck. It seems like you’re trying to register an extension right now, which might be taking a bit longer due to network congestion.