Last mint transaction failed (Metamask/Flashbots RPC). Endless loop of error messages

GM everyone! I am in search of a fix/solution at the latest stage of the minting process.
I am trying to batch-mint tokens on ETH mainnet. For my first batch, all ERC721 assets were minted on the testnet Goerli and successfully uploaded to Arweave.

I’m stuck on the last function: MINT.
The “mint tokens” transaction failed and was dropped. See this:
On the blockchain explorer, I saw this notification : This transaction was forwarded to Flashbots Protect RPC but was not mined and has expired.

On the RPC’s related-webpage, it is mentioned that the transaction failed due to low gas fees.

After finding out the above, I went back to Manifold Studio. Then I tried reloading the page as indicated. But, I stay in an ending loop which tells me that there is an issue and that I must refresh the page. I had scheduled today as the minting day. But it seems that I can not continue or do anything to finish minting the smart contract on-chain.

My current understanding of the issue is that Manifold does not pick up the info about the failed transaction because it was dropped before being included in the on-chain memory pool and didn’t result in loss of funds.

I would appreciate any guidance on how I can make the necessary changes directly on the contract via Etherscan (functions to call after connecting wallet).
Otherwise, I’m asking for anyone working at Manifold to debug or help me fix this problem.



Thanks very much!

1 Like

I have the exact same problem here. Would be great to know a solution by Manifold asap …

hey there, can you retry minting your series again and tell us if it works? we have not been able to reproduce the issue from our side.


hello, do you mind trying to mint your series again? there was an issue with our servers and retrying it now should work for you.

1 Like

It did work now - fab!

Here’s it on-chain :slight_smile:


No, I didn’t see any changes on this issue. Until now, I’m stuck with an error message : “Something went wrong, please check your connection and refresh this page to try again”, popping up on-screen. If I press OK, the page is refreshed and I go through the same process, again and again.
Link to the problematic series: Manifold Studio.

But, I found one way that allowed me to continue minting. I used Etherscan, looked for the smart contract and minted this first batch from there (and switched to a Cloudflare RPC endpoint). See this Twitter thread that I posted with more details: The minting transaction was validated on February 14th.

For the second batch, I successfully minted the tokens today (Feb19) by using Manifold Studio: All went well. Connected to a Metamask wallet, set to a Cloudflare RPC.

Then, even though the first batch’s tokens have been minted on-chain, when I tried to edit, view or update on Mainnet via Manifold, it doesn’t work. I am shown the same on-screen error message as last week before mint. So, I guess the issue is not resolved yet and I don’t know what else to do.

Thank you for your previous reply.

glad that you were still able to mint the first batch tokens!

even though the first batch’s tokens have been minted on-chain, when I tried to edit, view or update on Mainnet via Manifold, it doesn’t work. I am shown the same on-screen error message as last week before mint. So, I guess the issue is not resolved yet and I don’t know what else to do.

from your screenshot, it seems that tokens in that batch are still tagged as Goerli. since you minted the first batch outside of Studio, you will need to manually tell Studio about the existence of the tokens on mainnet. you can do so by going to your contract page → settings → “Add missing token” and specifying either the ids or the opensea link.

please let us know if that works!

1 Like

Thanks for help.

I followed your advice. Inside “Settings”, I entered one asset’s OpenSea link in the empty field of “Add missing token”. Next, a pop-up appeared. It says “You are not allowed to add tokens minted from extension contracts (Batch mint tokens, claim tokens etc.)”. Clicked on OK. No response, it closed the pop-up and brought me back to the “Settings” page.

Then, I did the same modifications, but with a token ID. No changes, still same message on a pop-up.

i see. this is indeed an issue. we are working on it and will notify you when the fix is out.

Hey there! There is some progress in the resolution of my issue. Today, I decided to login again and see if there are any changes.
I was greeted by a pop-up message with three options to choose from: cancel, speed up, paste txn. I chose to fill in with the transaction hash (minted first batch on Feb14).

Everything worked smoothly and I received congratulations for minting on Mainnet.

The next issue came up afterwards. I could no longer visually see artworks minted with that batch transaction although all web3 platforms display correctly the images and associated metadata. My guess is that there is some difficulties occurring with data storage provider, Arweave or IPFS node/partner.
I’m not certain at all. I just wanted to share news about this ongoing issue.

Tried to “resolve” it by following some of your previous recommendations. Failed to add missing token ID.

Failed to refresh metadata while on a single asset page. The pop-up notification showed an inaccurate message. Proof that it could not sync metadata.

Thanks very much!


There seemed to be an issue with the arweave network that prevent you from seeing the images on Studio. I just checked and things should be looking ok now, please let me know if you still seeing issues!

1 Like

Hey dongqtm,
You are right. I just noticed that my internet provider now blocks access to p2p networks over the internet. I can confirm that it was preventing me to view the images stored on arweave network.
Thanks a lot for your help!