Mainnet deployment error - problem with previous deployment, check internet connection

Was able to create the contract on Goerli testnet - Having an issue with creating the contract on Mainnet, have had issues for over a week with my wallet and Manifold. Longer actually, maybe this is related?

Screenshot 2023-02-24 at 9.13.35 PM

I think this may be related to a purchase I attempted from an open edition last month that didn’t clear through before I was closed. This was on Manifold as well. Please get in contact with me, would like to get this resolved or sort out what I need to on my end to complete this contract creation - thanks


Sorry for the issue you are having. Wondering if metamask ever pop up and did you have to confirm any transaction?

We did push out a fix last week that might have resolved this issue. Could you try again and let me know if you are still seeing this issue please?

Yes, I am still having this issue presently - wallet saying “Contract deployment failed”

Could I ask which wallet are you using, and which browser please?

Metamask on Brave, but I’ve also tried Metamask on Chrome - I believe this has something to do with my account as it relates to the backend of the Manifold site due to a previous acquisition attempt that expired maybe?

I do see a mintBatch transaction pending on your wallet. Are you able to cancel that transaction on metamask? You can see the instruction on cancelling transaction on metamask here:’t%20done%20this%20already%2C%20to%20cancel%20the,been%20confirmed%20cannot%20be%20reversed.

Is the one you are seeing from February 24th? I’m not seeing “pending” I’m seeing “Failed”

Checking in about this - I had previously already attempted the fix you linked a number of times.

This is the pending transaction that I am seeing

Let’s try to debug this issue together
Could you try to deploy the contract to mainnet again? When the error pops up, please follow these steps:

  1. Right click on the screen, choose “inspect”
  2. Choose “console” on the top right corner of the screen
  3. Please copy and paste the the error messages you see here

Thank you

If that is a pending transaction, it will not succeed. The gas provided is too low. Please cancel that transaction.

mdf365, can you confirm:

  1. The wallet you are trying to deploy with is 0xb92d691e5c68d1ea83da914109d78f335a1283d0

If so, 3 days ago, you tried to mint the following NFT:

Because, if this is the case, you had initiated the transaction with a gas price that is far too low and will not succeed. This will be an indefinitely stuck transaction that will prevent any blockchain transaction from your wallet until you cancel it.

If any of the above is not the case, please provide us with the wallet address you are trying to deploy with.

Yeah, sorry about the delay - Is this still stuck? That is the transaction (which says still pending on Etherscan but I’m not seeing in my wallet currently). I did attempt to cancel this transaction a while back when I initiated this thread by using the same nonce and increasing the gas/gwei. Not sure any of that went through but I can try it again.

Thanks for being patient and getting back with me

No problem. Let us know how it goes and if this resolves

I’m not seeing the pending transaction on my wallet but the etherscan link you posted still seems to be present - I don’t don’t know what that means or if it’s a discrepancy?

Ok. Even if you don’t see a transaction on metamask, it’s still stuck. You should be able to fix it by initiating a new transaction with nonce “1”. Any transaction will do, even sending eth to yourself. A deploy would also work, just make sure the nonce is “1”

This isn’t seeming to work - I set nonce to 1, tried aggressive and market multiple times. Not sure what the problem is

On metamask? You try sending a 0 eth transaction to yourself with nonce 1? Share a screenshot? Your wallet is basically blocked from making a transaction until the prior one clears out.

Yes, on Metamask - yes: 0ETH transaction with nonce 1

Yes. Odd. This should work and you should see the transaction on chain. If you try that again and it doesn’t work, try