Mainnet Metadata mix up - not updating from Manifold - critical issue


I have an urgent/critical problem with my collection deployed with Manifold.

I noticed today on Opensea that many of the items in my 8-Bit Sport collection seem to have been ‘mixed up’ - items appeared to be owned by different collectors.

Then I noticed the the token ID in the URL and the Item title number were mismatched on many of the items in the collection.

I logged into Manifold and checked all the items had the correct token ID to match the description, which was all good. I then checked the Metadata files. Rinkeby metadata is correct, however mainnet metadata is wrong for a lot of the tokens.

All tokens are correct in Manifold. However, I have tried to ‘update to mainnet’ but the metadata for the tokens is not updating to how the tokens are in Manifold. As you can probably appreciate, for a live sold out collection, this is a nightmare!

All items were correct for the last 6 month since the contract was deployed.

There are currently many items listed for sale. This could be a catastrophe.

Please can someone help, I have no idea how this has happened and no idea how to fix it. Is there a bug with Manifold?

Example Token

Token ID: 174
Item Title: 174 - Zico - Brazil

OS link:

Testnet Metadata:
This appears to be correct.

Mainnet metadata: I can only post 2x links as a new user. If you click the token ID OS and you will see it is showing the metadata for token 173 !

Please help, some of my collectors are freaking out over this, as I’m sure you can appreciate. Updating the collection as it appears in Manifold is not rectifying the problem.



So sorry for the issue you are having, we have discovered the bug and a fix has been deployed. If you hit “update on mainnet” now all your tokens should be updated correctly. You should not encounter this issue anymore in the future

Don Dang

Hi @dongqtm - I’ve updated the first couple of batches and it has not changed anything. If I click the three dots in manifold next to my tokens and ‘view metadata’ it is still wrong.

Example still showing incorrect data:

88 - Legends #27 | Manuel - Club Edition (Should be token 88 but is showing this metadata on token 89)

No doubt the rest will still be like this :frowning:

Could you send me the opensea link of the token that is still incorrect please?

Hi @dongqtm

Token 21 - 150 are all in a batch together. I have only updated that batch to mainnet since you advised the bug was fixed, yet it hasn’t fixed any of the issues with the tokens in that batch. I have previously tried updating all batches/tokens to mainnet, and the metadata is not reflecting what I have in Manifold.

also 88, 89, 92… and many more that are still incorrect. This is a huge problem.

You will see the metadata, for these is wrong. Token 75 should have metadata for item titled 75 etc…

In my Manifold dashboard all tokens have the correct description etc how I need them to be, as they always have been. Which is why I do not understand how this is possible. Does this all make sense how I’m describing it? Can you see the issue?

Thanks for your help


I see, the token you told me that was wrong was
Which I see now that it is fixed. This token belong to series 3

But there is another series that you did, series 2, which token
belongs to.

This is fixed now. Could you try “Update on mainnet” for this please? The series should be on this url “Manifold Studio

Please let me know if there is any other series, apart from series 2 and 3, that has incorrect metadata, I can get them fix too.

Any series you create in the future will not have this problem. Sorry about this :pray:


Ahh, OK. Apologies. I assumed you had fixed the issue across the whole collection. I think that has fixed them now, thank you.

So there are a number of other smaller batches that I created more recently. Would you mind checking them in case the issue is there but hasn’t jumped out yet:

next batch contains token 272

another batch … token 283

and lastly… token 288

thanks again for you help with this @dongqtm