Manifold Contract - MetaMask Error When Listing on Foundation

Good Evening,

I have a Manifold contract for an ongoing collection (Polaroids by Parra) that I created in 2022. There are currently a few tokens in the collection listed on Opensea, and a few days ago I minted a new token to the contract to go in a Foundation World. It is showing up on Foundation, but when I go to list it in the World, I get the following Metamask error on my Chrome extension: The error says: Message: Invalid data; should be ‘approve’ method, but instead is 'setApprovalForAll’.

I tried restarting my computer, clearing my cache, switching networks on MM, updating the extension, and I was able to also complete a transaction on Manifold (that was successful), as well as cancelled a listing on Opensea with no issues. I am still seeing the error and am unable to list. I reached out to Foundation and haven’t heard back.

Does anyone know how to fix this? Will I have to burn the token on Manifold and mint to a different contract I have or is it just a MetaMask issue?

Let me know!



Thanks for reaching out - Does this happen when you’re in Foundation?

Yes, this is happening on Foundation just on this specific contract. I’ve done this before with a different collection and didn’t have any issues. I have tried everything (including going to change prices on other NFTs listed on FND, which works and I only get the error when I am doing this on this contract. Do I need to burn it and mint to a different contract?

Today, Foundation sent me directions to follow that resolved the issue! I asked them what was causing this to happen for future reference and haven’t heard back yet.

Thanks so much! Parra

1 Like

Amazing! Thanks for keeping us posted!!

You’re welcome! If anyone else comes across this, below is their response with the step-by-step instructions of what to do in MM and also a link to what some other people experienced with this issue.

I think it was also because I had previously had the contract on Opensea and I had to have the remaining tokens approved to have Foundation have access to the contract from my wallet via MM. I remember this being a step when I listed “FLY by ParraDeSys” on Foundation as well, but I didn’t have the errors pop-up that time around.

Hey Parra,

Thanks for your patience. We’re still investigating but may have come up with a solution:

  1. Open Metamask and Click into the Tokens tab in oyur wallett (it should be below the buy/sell) button.
  2. In Tokens, you should see PARRA and the number of tokens that are currently in your wallet.
  3. Click on it and a modal should pop up asking whether you want to mark your tokens as NFTs. Confirm it.
  4. Once you’ve done the above, try listing your NFT in the world again.

If that doesn’t work, let us know and we can investigate further.

Do you know why it was doing it for future reference?
We’re not 100% sure, but apparently other users have faced a similar issue like this before. From this [thread] [[Bug]: Chrome setApprovalForAll function fails in Metamask for some collections · Issue #18507 · MetaMask/metamask-extension · GitHub] we do know its a known issue/edge case with Metamask.

Thanks again,

Thank you for the explanation! This will help creators running into the same issue.

Appreciate it!!

1 Like