Manifold not switching to Goerli

The website is not letting me switch from MainNet to Gerli. I don’t have any ETH on my account but I doubt that might the problem. Any suggestions?

Can you describe the error you’re seeing? Also, what wallet and browser are you using?

I connected my Exodus wallet to Manifold using my phone, and when I try to create my first contract I can’t switch network, the only working button is to deploy using ETH, I am trying to first preview the contract with Goerli and in the tab next to the gas icon I can’t make any changes, then I select Switch Network and it doesn’t work either. When I complete the whole contract the default is set to Test Network but i can’t move forward since there’s no deploy button. Short version I can’t change from Mainnet to Optimisn, nor Base nor Goerli, the only deploy option is switching network to ETH, because Optimism and Base don’t display the deploy button.

I am using Exodus and Chrome