Manifold Open Edition Claim Page not Showing Up in or Syncing with OpenSea Collection

I minted my second open edition claim page using Manifold and this time it will not show up in OpenSea despite it being 10 days after I minted it.

When you click on the OpenSea button on the Manifold Claim Page OpenSea shows the following message:

"The item you tried to visit is no longer available on OpenSea

The item you tried to visit is no longer available on OpenSea. It will not be visible or accessible to anyone browsing the site. To learn more about why the item you tried to visit is no longer available, read [our Help Center guide on this topic]. If you have questions or concerns regarding this action, contact the OpenSea team [here]."

I followed the exact same steps as I did the first time that I minted a claim page in Manifold, see the claim page here and this one shows up on OpenSea, so I am not sure why there was an error the second time I did this process.

A few other details:

  • No thumbnail shows when viewing the item on etherscan, which is weird (here is the contract number to search on Etherscan to see the issue: xc7f6c1ee86119e6bdc133233d30ddc06f7deaf66
  • Item shows up on Rarible from the link on the Manifold Claim Page but not on OpenSea…

Please advise. We are getting ready to launch our collection and want OpenSea to be a partner, but we need this linking to work properly for that to be possible. Thank you.