Manifold Studio unable to upload small images, stuck forever on "Upload time left: ~2s, Finalizing..."

This is an old bug in Manifold Studio, wasn’t resolved since first reported in Manifold Discord server about a half year ago.

I tried to upload very small GIF image, and it shows uploading forever. Same result when I uploading small SVG, except now it allowed me to “Mint to Goerli”. After minted it resulted NFT without an image.
Can see in

I am able to upload the same SVG on OpenSea directly, so I consider this as a bug in Manifold Studio.
When I can expect it fixed in Manifold Studio, any quick workaround for same image?

SVG image

Here is how it looks in OpenSea Testnets deployed from Manifold Studio
Here successfully uploaded SVG on OpenSea (uploaded directly from OpenSea )

Gm! If you reupload this file it shouldn’t be stuck any longer. Can you give that a shot?

Thanks Lyndo. It works now. I succeed to upload both, GIF and SVG. Thanks!

There is another issue I noticed. If I upload the GIF then after it I am no longer able to open my contract in Manifold Studio - Manifold Studio will redirect to Manifold Studio, happens also on browser clean cache. If I instead upload the SVG then all works fine and page can be loaded.


Do you mind sharing with us the GIF file that is causing the problem please?


Here the GIF image


Are you still having the issue with this GIF file?

No, it works now. Thanks for a quick fix!