Marketplace blocker not working / OS saying royalties are optional on my collection

gm gm, I just ran my contract and minted the first token (past the dates of being grandfathered in for creator royalties). So I installed the Marketplace Blocker app and selected the marketplaces to block. My OS collection page on edit mode said that my collection will have optional creator fees. Something must not have worked. So I then turned on the OS Operator Filter on the contract, but my OS edit page still says my collection has optional creator fees. I tried to update the Marketplace Blocker’s list of markets I blocked and it wont let me update. Not sure what to do now, any help or insight would be greatly appreciated, thanks!

Thanks for reaching out - To confirm you’re seeing something along these lines:

Screenshot from Manifold Studio where the Operator Filter has been enabled:
Screenshot 2023-01-06 at 1.56.41 PM

Screenshot from Opensea where it looks like royalties are still optional:
Screenshot 2023-01-06 at 1.56.54 PM

1 Like

Yes, that is exactly what I’m seeing, any idea what’s going on? Thanks for your help!

I’m having the same issue. I reached out to opensea but no response.

gm gm Lyndo, just following up on this, do you have any help for us?

gm! Thanks for the follow up. We’ve reached out to Opensea and they will have a fix in tomorrow

Following up! There should be a button on Opensea that will allow you to refresh

Thank you, yeah that worked! I have one more issue I’m wondering if you can help with that is related. Before I turned on Opensea’s Operator Filter, I initially tried to do it myself with the Marketplace Blocker App, but then I turned on OS Operator Filter. I can’t update the Marketplace Blocker app now, is that because I turned on OS Operator Filter? Do I need to update this or did the Operator Filter settings now override everything? Thanks so much!

I have the same question