Ongoing transaction error

Hi there, I’ve been experiencing issues with my dashboard. About a week ago, I had a failed transaction and since then, I haven’t been able to perform any actions. Whenever I try to mint or do anything else, I get an error message that says there is an ongoing transaction in progress. It’s been a week now and the issue still hasn’t been resolved.

What do you see in Metamask? Can you try clearing your local storage?

The browser is not the issue here. I have tried different browsers but the problem still persists. The issue is with my wallet. Even after clearing the local storage, the problem hasn’t been resolved.
The trouble started when I was creating a new contract and my Ledger wallet was locked, causing the transaction to fail. Now, there is a pending transaction on my dashboard that prevents me from making any other transactions.
Besides, there are no pending transactions in my Metamask
Screen Shot 2023-05-01 at 9.08.11 PM

Marking this as resolved since it has been solved here