Snapshot tool Did not produce snapshot, dev portal

I tried the dev portal snapshot tool at 4:00pm PST today and it did not show up in my studio home page. it said it should take an hour but it’s been much longer. Thanks.

The snapshot tool will produce a snapshot in the Dev Portal. It will be under the Campaigns section.

Actually, I spoke to soon the soon. The snapshot is empty except for some strange chars. (  )

Can you screenshot what you see on the developer portal under the “campaign” for the snapshot?

I tried it again and this time it worked, so not sure what happened…but I got the snapshot! It looks like the Merkle root didn’t transfer on the first try.

I have the same issue you had first time

The snapshot just produces and excel file with this

My Merkle root is also 0x

Do I need to populate it or should it happen automatically ? I have tried twice with the same result?

These are the two snapshots I created


This is screenshot from 474691451

Can anyone help with these please?

Im clearly missing something as 7 snapshots have turned up blank

Contract 0x34749dc5ffa06c7dcfb80c723e7d8dc65e754933

The snapshot file returned looks like this when opened

Ok, the reason is because the snapshot didn’t actually contain any tokens in it (you can see it’s missing the tokens when you view the campaign).

When you create a snapshot, you have to be sure to click “Add Token” and it needs to appear at the top.

We’re going to fix up the UX so it warns if no tokens were added.

That worked thank you very much

gm wilkins,

I’ve added the token as you suggested, filtering by Tokens by Attribute, but the file is empty, same as the users above reported.

Attaching screenshot for reference:

Oh, it’s because it’s looking for tokens that match ALL the attributes (of course, there are none).

If you want to get tokens specifically matching either of them, you’ll have to add multiple rows/tokens to snapshot. Not just one record.

this worked thank you very much dear wilkins