Stuck in the first step of claim page

Hi, I’m building a claim page for the first time. I don’t understand what is the problem, but I’m stuck in the first step and cannot proceed or adding more properties. Is there any rule for image or for text?Someone can help me?

I see the next button isn’t enabled. Have you tried clicking near the button and see if it enables? Usually it’s greyed out if a certain field is missing.

Did you ‘paste’ in the artwork title? Try removing and typing in a character. We may not be detecting auto-complete properly.

Hi, no it doesn’t work…and the grey button isn’t enabled. All the field are filled I tried to remove the website link which is optional but it doesn’t work anyway…maybe is there an error in the previous steps, in the contract? Here is the link of the contract:
I used the same image of the collection and NFT for others tests in Opensea, like a year ago I don’t know if this is a problem…

Can you try again, set up the claim and upload the assets, then send a message? I cannot seem to locate your draft claim page.

We just deployed a change that should show you why it’s disabled.

Can you try again, then hover over the next button? It should tell you why it’s disabled.

Please take a screenshot.

Hi, still not working…

There’s no message telling why it’s not enabled…

That’s odd - Would love to get a bit more information, sending over a DM!

Can you clear your browser cache and try again? It should definitely show you a tooltip when you hover over the next icon for 2-3 seconds without moving your mouse. Try that before you even upload any assets.

I just checked out your claim and it appears that I can click the ‘next’ button. Can you try clearing your browser cache?