Token Gated Plugin: Several Issues

Gm Many Folders,

Was stoked to discover the “Token Gated Content by Orvylle” plugin, as that’s the type of functionality I’ve been after for a while now for different personal creative projects.

In short, the aim is to have a contract with a token that allows holders to unlock a token-gated page that allows access to download the Blender file for a 3D build (which has more inside it than just the GLB minted through Manifold).

Trouble is, I seem to be hitting a number of issues which I can’t find solutions to – a couple of which seem to have been raised here before but don’t seem to have been resolved. For example:

This is the first issue I hit – exact same thing:

(Note: The title says “T” because I created that one a few days ago as a placeholder to test functionality, and I think I had started typing “Test” when it autosaved the title.)

The client-side application error started happening right after I entered the contract address I minted this morning (which did not yet have tokens on it), so I’m not sure if that triggered the issue, but the page is no longer accessible to edit/change anything on it.

Here’s the console error log it requests if that’s helpful for troubleshooting:


Similar to this, after the initial bit I started typing, it keeps erasing and going back to what I had initially typed after a bit – it seems to not be saving any new edits/text in the main area, and there’s no save button to try to do it manually (vs. the autosave Manifold typically does mostly everywhere).

There’s a fair bit more typed, but it keeps ignoring when I add new text and just defaults back to what (I’m guessing) was first autosaved, as seen in this screenshot:

(Note: I haven’t added the token requirement yet as I don’t want to nuke the page if the first error happens again, and I haven’t tried uploading the .blend file yet as I’m still working on it – I was just trying to lay the groundwork on the manifold side first to make sure I can make this functionality happen.)

Also, I’m hitting the same issue mentioned in that post where it says the plugin is not installed, so to access it I keep hitting the “install” button:

I’ve tried this on multiple computers and browsers in incognito mode, so it does not appear to be a caching issue. (Chrome seems to have a whole different issue where after “installing” the plugin, it just shows the “Created by Oryville” logo + page in the App iframe, and nothing else.)

Any hepl/assistance in sorting this out so I can use this beautiful plugin to its potential would be super appreciated – thank you, friends of many folds!


Thanks for the super thoughtful feedback!

I’m doing this on the side and currently don’t have much time to look into these right now :frowning: But taking note!

Another alternative you could look into in the meantime is either:

They offer token gated solutions for you! Probably better suited since they are a full company working on them :slight_smile:

1 Like

I feel that – there are only a few hours here and there I can find for my own passion projects where I’m solo dev (the one I’m looking to use the token gating for is currently one of those).

Love the potential of this token gate being within Manifold as a plugin app, but I’ll check out those others in the meantime – I appreciate your response and direction (and dev work developing neat stuf for the friends of many folds)!



Looks like new text isn’t sticking still, but I was able to token gate to the contract I wanted to, and then iFrame into oncyber (the endgame for what I’m working on).

Ran into a couple of things I thought you might want on your radar when you have some time to work on it again.

Spooky message wen trying to log in with a wallet to verify holdership:


Thinking I’ll have to go with one of the alternates you recommended for now (tho I love the idea of doing it all within Manifold – one day! I know that “!wentime” feel for passion projects all too well).

So close: