Too low GWEI, cancelled and now can't mint again

Hi, I tried to mint a token ERC721, I set the GWEI to 14 and later changed to 15,5 but it never minted after 3 days and I couldn’t speed it up anymore. SO I cancelled the mint which had succes but now I can mint the token anymore, it’s giving this message and no matter wat I click it doesn’t bring me anywhere

Is there anything else I can do to continue minting?
Here’s the transaction hashe

Can you try clearing your browser cookies to see if this resolved the issue?

Hi, yes I cleared cache it doesn’t help

What happen if you hit “cancelled”? Are you able to mint again then?

No, nothing happens when I hit either of the 3 buttons…

Every time I try one of the 3 options, I get the same message with the 3 options again

This is what happens after I press cancel, it is not asking for a signature in Metamask, but it would need a signature for the mint to go through…

I see, so it never asked for your signature, and pop up the error message modal instead?

After I canceled I can not get any further than this popup screen and “waiting for”

Could you try again now and let me know if hitting “cancelled” let you mint again please? We have made a few fixes on our server

still not able to mint…same message comes up

Ok, it works now, I cleared cache again, thank you!