Unable to airdrop 721's via claim/edition page


I am trying to airdrop tokens to collectors via the claim/edition page but keep getting this result. This popup appears and lasts for a split second before disappearing. Nothing else happens.

  • I am on Brave Version 1.45.127 Chromium: 107.0.5304.110
  • Using MM.
  • Have tried restarting browser
  • Have tried logging out and back into wallet
  • Have tried disconnecting and reconnecting to the studio.

Video of the behavior (cannot share the video directly in the forum): Dropbox - ScreenRecording 2022-11-16 at 11.56.05 PM.mov - Simplify your life

Hi! Could you tell me the name of the claim that you trying to airdrop, as well as your wallet address please?


  • Wallet address is tjthorne.eth/0x6C0040BdA93e4Cf433c0aa8498bD624397aECe30
  • Angulation


I was wondering if this was being investigated at all.


Sorry for the delay, would you mind trying again please? If the error still there, could you right click on the screen, click “inspect”, then go to the “console” on the top right, then copy the error messages here please?

Thank you!

I tried it again with the same result, but also discovered a couple of things:

• It will work if I try to airdrop to a single address. I even upped it to 9 tokens and I still got the transaction approval to pop up in MM.
• I tried it with two addresses, a single token each, and experienced the issue I have been having.

Here is the message that was in console. I am pasting it as a screencap as it will not let me post since I am a new user and am limited to two links in a post:


Could you send me the list of addresses you want to airdrop to please? It seems like you are trying to airdrop to addresses that cannot receive 721 tokens

Sure! Here are the addresses I received after using the snapshot feature. Is it because one of them is duplicated?:


Oh wait!! Now that you say that… maybe it is because two people have them listed for secondary sale on Foundation which moves it out of their wallet and into the Foundation escrow wallet?

Edit: That looks to have solved it. I replaced the 0xcda…0b6f address with the two addresses of the collectors and I was able to move forward with the transaction.

Thank you for your help!