Unique metadata on Burn Redeem, OS IPFS linking to wrong token

I followed the instructions provided here to upload my own metadata that was stored via IPFS. I would have done this via the studio like the video commented shows, but i wasn’t seeing this ability for burn redeems. The metadata is uploading fine, but they’re linking to the wrong tokens. You can see the first screenshot that shows the token I am looking at, and then the second screenshot is the URL i am brought to upon clicking that token ID. Is there a method I can call that correctly links the two? It seems like its using the token id from the arweave paths that used to exist.

Screenshot 2024-01-08 105224

Thanks for reaching out! We’ll need a bit more info - Can you share a link to your Burn Redeem page?

Thanks for looking into this! The end goal is there’s 3 different burn redeems we’re doing this for. Here is the one in which i have updated the metadata to use IPFS

And here is an OS link to one of the tokens

Its correct metadata link should be

Any chance someone got to take a peek at this?

Just wanted to follow up again, before implementing a non ideal solution :laughing:

gm @gbgz ! Thanks for bringing this up. The way the contract works is by incrementing on the specific Burn-Redeem that you have setup.

Let’s take token 16 for example -


As you pointed out, this points to ...ipfs.../3, when you might expect it to be more like ...ipfs.../16

What this indicates to me is that this is the 3rd token that was minted on this specific Burn-Redeem campaign (Mehretu)

So - what you essentially need to do is -

  1. Upload a new folder to IPFS, with the correct numbering
  2. Update on-chain like you’ve been doing

This is typically not too difficult, as you can usually just shift the numbering. Say on contract X you’ve minted 5 tokens, and then the BurnRedeem tokens are tokens 6-10. Then you just shift by 5. Looks like you have a mix of different methods to mint on your contract (0x04385b64cbeec318d2621d066d4597300fad83f8) such as a few different BurnRedeems. So it may be a bit of manual work there.

Let me know if this makes sense or if you need any other help!

perfect, this is the solution i was going to implement, but I just wanted to make sure that there wasn’t an easier way. Thanks for the update!

1 Like

Yep! That’s it, a bit of a hassle, but glad you figured it out!

I updated the metadata a few days ago. Its not reflecting on OS even after hitting refresh endpoint. When i go to the contract’s tokenUri method its showing the correct link in ipfs format (anything over token 7 uses IPFS). But OS is still showing the arweave links. The metadata has been updated several times and this issue is the first time its arose. Any thoughts?

This doesn’t load for me -


What service are you using to pin your metadata?

hm interesting, ill try to upload it somewhere else. i pinned it with nft.storage

I re pinned the metadata on pinata, and OS still is showing arweave links even though that tokenUri method is showing the correct IPFS links


This is great, I can load your metadata now. I see that OS hasn’t refreshed it in 12 days. I tried clicking refresh, just waiting for them.

Have you tried the refresh metadata button on all the tokens? Might just take a bit for OS.

I have tried that as well. Still not seeing OS refresh at all though. Strange as I thought it was usually pretty fast

Hmm weird. Will reach out to them and get back to you

Thanks for your patience @bgbz !

OS is having trouble parsing the JSON from the token. Looks like you have it stringified there.

"{\"created_by\":\"Print Editions\",\"name\":\"Mehretu #3/250\",\"description\":\"Print Edition Certificate...

should become more like -

{"created_by":"Print Editions","name":"Mehretu #3/250","description":"Print Edition Certificate...

You can note the difference between the original arweave link and yours reflects the same changes.