Upload Never Finishes - Finalizing

I believe something is currently wrong with uploading images. It sits at “Finalizing” indefinitely. I have tried two different browsers and two different contracts with no luck. Thanks in advance for the help.

1 Like

Same here, my image upload is stuck on the spinner. Other metadata uploaded just fine, but image isn’t taking today.

1 Like

Thanks for reaching out! We’re investigating and will keep this thread updated: File Upload Error (April 13, 2023)


This should be resolved! Let us know if you’re still having issues

1 Like

thanks lyndo. getting further along in the process this time, but still seems to be chugging more than usual.


What is the name of the claim you are trying to upload? I can take a look

1 Like

I was able to get my mint out! Thanks Lyndo!

here’s the url – brain wave[s].

claim page won’t load the artwork and app token page says it’s out of sync with the blockchain. tried to update yesterday and again today, still getting the arweave upload modal message.

What happens when you click review? Can you screenshot the modal? There is definitely an issue with the claim and a transaction has to be executed to fix this.

You can try re-uploading the image again, which should resolve the problem (be sure to perform the transaction after you upload/save)