Wallet Connect Error on Mobile IOS

It’s because your developer didn’t actually ‘fill in the blanks’. Here’s what’s on your site:

Notice where it says ? You’re supposed to put in your websocket provider you got from infura.io or another blockchain node service.

thanks. I think that is solved now, but there is still one more issue. It appears to be working correctly on mobile, but on desktop using Chrome, it appears to be connecting to the wallet without asking me to sign MM. Is it behaving this way for you as well?

Yes, you don’t have to sign anymore with the modifications I suggested.

ah got it. If we wanted to make it so you did have to sign MM once to complete the wallet connect, can we have a slightly different modification? I think having the Wallet connect experience the same as it would be on Manifold gallery or most other marketplaces might be the best option. It threw me off a little to not have to sign. I was surprised that wallet just connected. I thought there was something wrong. I think others may have a similar reaction.


Yup, if you want that signing to happen, flip this to false:


got it! thanks! great to have both options.

Unfortunately, I am still having issues with this. Please let me know how this is working for you currently in both mobile and desktop chrome.

I am hoping it may be possible for you to see what may be causing the problems All we had played with was flipping between true and false from your previous directions and now we are getting totally different behavior when trying to connect.

Mobile is asking to open in a different page and appears to be inconsistent sometimes going back to the MetaMask app, I don’t know what is going on now. I really need to get this to work.


Dm’ed you as well. Happy to help resolve rest of the issues. Played with the site and it seems to be working pretty well for me on mobile and desktop.

Hey! Yes, everything seems to be working pretty well. I think we got it. Thanks so much for all of your help with this.

Hi, I’m having an issue with the widgets loading on my site. Appears to be in the Manifold side, not an issue with my site.


would love to fix this as soon as possible. Please let me know what you think is causing this. Thanks

Ah, it’s because you’re using /latest for the connect. You should pin to a specific version because ‘latest’ is incompatible with the marketplace widget you’re using.


Ah, I think I understand. going to reach out my dev, but may just need to know exactly the place to replace the word “latest” with the specific version. Thanks!