Wallet Connect Error on Mobile IOS

I have MetaMask installed on my iphone and it works fine connecting with every platform I have tried connecting with except Manifold.

When I go to any Manifold listing in Gallery it says “Install Wallet” even though I already have Metamask installed. If I click on the button it then takes me to download MetaMask even though I already have downloaded it. If click on that, it then opens up MetaMask on my iphone, but it is not connected.

There then is no apparent way to connect to Manifold from Metamask. If I try again, it is just an endless loop. I have tried in both chrome and Safari.

Would like to get this fixed. If this is not just me and other people are experiencing this, I would be curious to know.

giving this a bump…would love to get a reply.

Can you share a link, screenshot and any other details that can help us reproduce? We are not able to reproduce.

Are you using the metamask browser? If not, you have to do this for iOS, or connect to metamask via wallet connect.

Ok, I have not had to use Metamask Browser to connect to other sites. I just tried that and I see how that works, but I would like to involve wallet connect. That appears to be what pops up on other platforms that I am used to when attempting to connect a wallet.

So are you saying it is possible to involve wallet connect with the widget on my site via the backend so the user experience would be like these other platforms? or are you saying that you download wallet connect on your ios as well? I’m not sure I understand clearly.


We just enabled Wallet Connect without the metamask browser extension so this should work now. Can you check it out?

That appears to be working directly from the Manifold listings, but does not appear to have updated when trying it with the widget versions of the listings on my site. Is there something I would need to update in the code on that end?

Ah, are you using connect-widget with data-multi=true? You need to enable multi wallet connection options.

What is the correct version? I am looking through the code now. My site is on wordpress and I had a dev help me with this…She won’t be available until Monday, so I am going to try and figure this out myself.

This is what I am seeing on the actual NFT listing pages we have:

< script src="https://identity.manifoldxyz.dev/2.1.0/walletIdentity.umd.min.js"></script >
< link rel="stylesheet" href="https://identity.manifoldxyz.dev/2.1.0/walletIdentity.css" / >

would I just change it to version 2.2.2? and then where would data-multi=true go?

then we have [data-widget=‘m-connect’][data-app-name=‘Curate1’] in the CSS customizer for the site

Yes, you can change to 2.2.2

and where you have the css customizer stuff, try:

Hmm, just tried that. It appears something is still missing.

there must be something else she did with the css customizer. Hard to tell without seeing the whole source code. She should know how to add this property though.

Still having issues with this. We are trying to use the same Wallet connect button across the entire site. There are 2 problems.

  1. On Mobile (IOS) it is requiring you to connect separately on each page, instead of once and then being connected as you browse through the site and the different NFT Manifold listings. These lisitngs were all are done within the same Manifold account.

  2. it is not working correctly on pages that do not have NFTs, but just have the button at the top of the page. it will not stay connected.

Here is a link to my site: https://tinyurl.com/y4hzpp4t

Ok, a few things to try here:
It does not seem like you need the data client, so unless you need auth for some reason, use the prop:


Once you do that, please message back and I’ll test it again. I’m having success on Dawn mobile browser and iOS.

Also, I noticed your identity widget component is referencing an invalid version. The proper version is here:

We just released a patch. Can you try clearing your cache and seeing if the issues are resolved?

Cleared the cache and tried this after making the changes. The widgets are not loading on mobile when the wallet is connected and you browse different pages. The wallet does stay connected however.

A few things here:

  1. Make sure you are using 3.3.10 for all the marketplace js and css (I noticed a mismatch of 3.3.0 for the css and 3.2.1 for the js)
  2. To make it load faster on mobile, include a data-fallback-provider on the connect-widget and marketplace-widget properties:
    Data Attributes - Manifold Docs

thanks! will update shortly and report back.

My Dev made the changes you suggested, but she told me she needs an API key. Is this correct? Where do we find this?

I found this documentation: NFT Information Retrieval - Manifold Docs

I forwarded this to her last night, but I am not sure if this is what she is talking about. What are we missing?

The wallet connect button is currently not connecting on my site, so I need to solve this as soon as possible. Thanks.