Burn Redeem Issue on Live claim - Issues with multi requirements

Hi, I’ve created a burn/redeem for ANY 2 tokens in my collection and its making people choose 2 of the same tokens to burn. I have never had this problem, usually when I choose any it lets people mix and match? I even tried editing the claim so its any token from token ids from 1-84 and still the same issue

1 Like

Are your burn tokens 1155’s? Can you share a screenshot of your settings screen and share a link to the burn?

1 Like

The person that knows this code is out for the weekend. Will this burn be active for longer than that?

Well I was just gonna keep it open for 24 hours, kind of a bummer because I was hoping to get some more momentum here

ok, we’ll try and look at it soon. Will update thread with more info as we have it.

1 Like

thank you so much, I really appreciate it

heyo gonna take a look asap. probably in a few hours. will report back

Thanks broski, you are the best

Good morning frens, any update on this? Its still doing the same thing on my end and lots of people messaging me about it. Forces you to choose the same token you have duplicates of.

1 Like

Im also now getting this error that says "cannot read properties of undefined (reading 'push)

Any updates at all you can provide me that I can relay to my community?

1 Like

Debugging as we speak! Couldn’t solve before I hit the hay last night. Round 2 starts now. Thank you so much for the patience dude, and the screenshots. Helpful.

1 Like

Finally uncovered the issue, just took a bit to recreate. Should have a fix out very very shortly. Will report back.

1 Like

Should be all patched up now! Give it a go.

Step 1 should allow for mixing and matching of the erc1155 tokens in your wallet that are eligible for that step of the Burn Redeem.

Only caveat for the future until further notice:

  • You can’t mix and match ERC1155 tokens on Step 2 and higher. Only step 1.

So if you make a 2 step burn, users will only be able to select a single token for that second step. It will force it to be the exact amount that is needed for that step’s criteria to be met. We will update this ASAP to be less restrictive but I wanted to unblock ya as fast as i could.

its still not letting me select any token I only have 1 of

Also for the future if you ever run into an issue like this and are in a pinch:

  • Update the burn to be more steps than one.
  • Make each step a “burn 1 of anything from this contract”

That will allow them to select one token on each step that may or may not be different from the token on the last step. Cheers Guido!

Gotcha, I can patch that. My tests I have multiple of every token I’m using so I missed that edge.

I dont fully understand, but its not letting me mix and match tokens, only tokens I have 2 or more of

I understand what you are saying, step 1 any 1 token, step 2 any 1 token

1 Like

Im gonna try updating it the way you mentioned, 1 for step 1 and 1 for step 2