Error submitting transaction | Reason: You must give the listing permission to transfer your tokens

I minted this on 4/20 and three days later I’m still having trouble getting the listing to work properly. I have updated this on mainnet multiple times to try and fix it, thinking it may have been a problem with file size or metadata, but something else is wrong. My friend showed me he could not submit a transaction to buy one, and I asked him to send the payment to my other wallet so I could test it myself, and had the same error message. I have seen other new listings for $PEPE which are successful and working properly, with the same file dimensions, supply, and price, so I know it’s not all of $PEPE listings having this issue. Also, I’ve tried to view the gallery listing on Microsoft Edge on both my PC and mobile, and it’s just not displaying the image. It says “Sorry, an error has occurred.”

:point_right: Gallery Listing of “OG Pepe”

GIF of Screen-Recording-of-Error-with-Submitting-Transaction-for-OG-Pepe reduced file size

GIF of Screen-Recording-of-Error-with-Microsoft-Edge reduced file size

Can you send a link to the listing please?

1 Like

Also, can you explain to me what you are trying to do? I see ‘Connect Wallet’ button, which means you aren’t connected. What wallet are you trying to use/are you trying to use wallet connect?

1 Like

Also, note that, when you do an ERC20 listing/purchase, the user will be asked to allow the marketplace to transfer tokens first. If they reject this request, it will result in that error. Were you prompted to allow the marketplace to transfer PEPE tokens?

1 Like

Just updated it to include the link to the gallery listing, and added videos.

With or without the wallet connected, on Microsoft Edge, it displays as “Sorry, an error occurred.” across devices. On Brave and Chrome, it displays properly.

Can you give it a shot now on edge? We just made a change that should solve this issue on that browser.

I did not reject any requests. If there was a request to allow the marketplace to transfer $PEPE, I would have accepted it. I think it did request that when I listed it for $PEPE, but don’t know.

Yes, that’s amazing, it does work in Edge now. Well done. That’s one thing solved, now how can I fix this listing and give it permission to transfer my tokens? Should I cancel the listing and try to list it again?

No, it should work fine. When you click buy, it should pop up a transaction request asking you to approve transferring tokens. AFter that goes through, it should ask to sign a second transaction. Is that not happening?

When I click the button to buy, it just gives me and my friend that error.

Is this brave only, or on Firefox as well?

I just gave it another shot on Brave, Firefox, Edge, and Chrome, and it’s no longer giving me an Error message, now clicking the Buy button is just doing nothing. And my friend tried Safari as well.

This is what you should be seeing after you click buy:

Are you trying on desktop or mobile?

Trying on both desktop and mobile, not getting that pop up, only the error message.

Please give us the following info so we can try to reproduce. We are not running into this issue on our end:

On Desktop:
Operating System
Hardware Wallet? (and if so, which one)
Wallet Address you are connected with (so we can check if you were already approved)

If you can, a screen recording of what you see on desktop would be helpful as well.

In our testing, on Chrome + Metamask, the following occurs:

  • Click buy will ask to connect wallet
  • Click buy after connection will trigger the PEPE verification request
  • After that, it will trigger the purchase action

OS: Windows 10
Browser: All of them I’ve listed (Firefox, Brave, Chrome, Edge, Safari)
Wallet: Metamask and Trust, no hardware wallet
→ My friend used Metamask and got the same Error that I’m getting with Trust wallet connected.
Trust wallet address connected: 0xe8642BC682cc254948a4C6F9EdC6bB118D3fdd81

It’s alternating between displaying the Error message and doing nothing when I click the Buy button.

These two videos are recorded from Brave browser (Top) and Chrome (Bottom):

GIF of Screen Recording of nothing happening when trying to buy OG Pepe on Brave reduced file size cropped

GIF of Screen Recording of nothing happening when trying to buy OG Pepe on Chrome reduced file size cropped

Very odd, I’m testing and cannot reproduce.

How are you testing Safari on Windows 10? Safari is mac only.

Can you pull up the error console and see if anything comes up?

Safari is one of the browsers my friend tried to use.

What’s your error console show?

In the second one, you’re using WalletConnect with which wallet? Are you always choosing WalletConnect?