Invalid Transaction - Error in Txn: Contract Creation Code Storage Out of Gas - Contract Deploy Pending

Hi! I am working on deploying a contract and kept getting an error saying “There was a problem with your deployment, please check your internet connection and refresh this page to try again.” and report if it happens again (screenshot below)

I refreshed and got to “awaiting execution” and the same error occured. When I tried again I checked etherscan and 3 transactions occured taking $40 in gas from my wallet each time.

I tried to put the transaction hashes from etherscan in and kept getting an error.

Screenshot 2024-02-20 at 10.33.04 AM

Etherscan says that there is an “error in Txn: contract creation code storage out of gas” but I’ve never had this issue minting on Manifold. I don’t know how to make any gas changes with Metamask.

I need to have this contract deployed by Thursday, February 22nd. Any idea what may be the issue?

Thank you!

Hi, looks like an out of gas error/issue with gas estimation. What wallet are you using and are you using wallet connect?

Hi! I am using metamask through wallet connect. When I tried to deploy the contract again so I could adjust the gas to agressive in metamask the transaction wouldn’t go that far - it just stalled in the “awaiting execution” phase.

Yes, we’ve identified an issue with Wallet Connect. We’ll fix this right now and let you know. Once you successfully deploy, we’ll refund you the gas you spent on this.

Sorry about that and I’ll give you another update shortly.

Amazing! I really appreciate it. How are refunds done? Can it be sent to the wallet where the transactions occurred?

Wallet: 0x3EcF068B735c6b5Cc7597E72CeCED9BdED196B82

Yes, we’ll send the funds there after you deploy successfully.

Can you clear your cache, refresh studio, and try deployment again?

Absolutely - I won’t be able to try again until tomorrow (Wednesday, February 21st) as it is a bit too late where I am. Can I return to this ticket tomorrow with an update?

Yup, anytime you want.

Hi @wilkins.eth!

I cleared the cache, refreshed the studio and deployed again - twice!

Each transaction today got to the “awaiting execution” step on Manifold, then deployed on Metamask and then on Manifold it stalled and the popup comes up saying there was an error in deployment.

The contract is still pending on Manifold and it’s been a really difficult process all around - and I’ve never had this problem on Manifold. Everything is typically very straightforward.

Can I please have all of the funds returned to my wallet? I lost over $200 in fees.

can you please include some log here please? left click and click “inspect”

hi @hmbui36 - I am unable to do that. Can we resolve this with the fees being refunded to my wallet please?

let me check and get back with you as soon as possible. For sure that you will send the funds back to you. Sorry for the inconvenience.

Don’t worry, we’ll reimburse the fees. It looks like it deployed successfully but we didn’t pick it up. Investigating.

Thank you - I’ll keep an eye on this page.

Ok, your contract is deployed, do you see it now? It should show in studio as verified.

We’re going to send you 0.08668445481229323 ETH for all the failed transactions and the deplys to 0x3ecf068b735c6b5cc7597e72ceced9bded196b82.

Can you confirm that looks right to you?

Thank you - 0.08668445481229323 is correct.

0x3ecf068b735c6b5cc7597e72ceced9bded196b82 is the correct wallet.

hi @wilkens.eth - was your team able to refund these fees? I don’t see them in the wallet. Would you be able to give an estimate when I should expect to see these funds?

Reimbursement transacton complete:

Thank you so much @wilkins.eth!