Trouble Connecting MetaMask to Manifold

Greetings, friends. I am in need of help. I tried everything, but I cannot seem to connect my MetaMask to Manifold, no matter what I try.

I tried in Chrome and Brave. I also tried another laptop with Chrome and Brave, and still nothing.

Error: “Could not connect to Chrome, please try refreshing your page. If you continue to have issues, try closing your browser and reopening it.”

Any help would be greatly appreciated.

Edit: MetaMask works just fine in other Web3 sites like Foundation. Only Manifold won’t accept it.

Do you happen to have any other wallets installed other than metamask?

Yes, I do. Phantom and Solfare.

I see. One of those wallets is likely interfering with metamask. When you see a message “could not connect with chrome” it means something is overriding the metamask wallet.

Could you try disabling those other wallets to see if it resolves the issue? If it does, we can investigate on how we can correct this.

Thank you so much, friend.

Did it work out? Let us know and we can dig further.

Yes, friend. It has worked perfectly, thanks to you. I am sorry for the late response as I was not able to see.

I have a new problem now 2 weeks later… :))

What’s the other issue?

it is here, my friend.