Uploading CSV to update metadata

I’m trying to update the metadata on a series of 721 I minted. I downloaded the CSV template, updated the template with my custom info, and when I click “UPLOAD CSV” and select my file, nothing happens. This happens both when I click into it to select the CSV from my computer’s files and also when I drag and drop the CSV into the box.

hi jvck,

sorry about that - this should be working (just tried it myself)

Could you share what your CSV looks like? Only should need the first couple rows. Also how many rows is the full csv you are trying to upload?

Here’s the CSV. It uses 13 rows total.

What I want to do is update the image for each individual NFT in my collection. It’s a total of 11 NFTs.
My understanding of how to set it up is that each line after the first two lines (name and string) correspond with the edition number of the 721s.
So what I’m doing is, for example, for edition #5/11 I’m adding a google drive link with the updated image to line 7. For edition #9/11, I’m adding the drive link with the image to line 11, and so fourth.

Just deployed an update. Should work now - can you try again?

Might I throw my hat into this circle?

I have a problem with this new UI layout. I don’t see the old “upload to Arweave” button to hit before publishing my update.

Further, after loading my csv of data, when I click publish, I get this error thrown :
“Cannot have an instance allowlist with this audience type. Please refresh and try again.”

What’s the problem? I have an open mint with no ending, a supply of 999, and only 24 are minted so far. The allowlist setting are open to anyone.

Thanks in advance

My comment above was meant to be a reply to your last comment.

Hi. This shouldn’t be an issue any longer if I understand the issue correctly. Can you try again?

I got past the error I reported.
Now, after a lengthy wait, I got this…

Is it continuing as it says? Or do I need to click “Retry?”

Yes. Just click retry.

Managed to get all the way to a succesful upload, and a signature in Meta mask to publish changes then, pushed and hit “Error 403”

The console is active. Seems the page is still attempting/processing the upload to Arweave.
However, there are no thumbnails (As there were only links to MP4 files), and when I click to edit an individual NFT, there is no indication that any data is associated with it.

Looks like error 403 has to do with file dimension “Maxwidth= 1024”

Am I getting that right? Are my files the issue?

403 means that your session probably timed out. Refresh the app and give it a try.

Note that we’ve just increased the session expiration timeout so you shouldn’t encounter this issue anymore.

Refresh worked. Got the MP4 files pushed onchain!
Follow up issue. The thumbnail cannot be generated from an MP4 frame. So now I need to reupload a still for a thumb. Is there no way to display the animated content as a still for thumb?
I cant go snipping 999 stills for this.

Anything I need to do for this synch error displayed?

That warning just means that what we have on our side doesn’t match what’s on chain. Republishing would fix this.

As for still images we don’t automatically generate a still because we don’t know what part of a video would be representative.

That all makes sense. Thanks.
Even though it isn’t default, is there any way at all to generate a still?
Without a manual effort on my end :slight_smile: