Websocket provider field disabled in Studio


I’ve setup a Gallery listing, but the input field for websocket provider in Studio is disabled.

Is there a way to resolve this?

I have setup a Gallery slug: https://manifold.gallery/coda

Another Gallery listing that previously had a websocket provider added via the old Studio now appears to not use it — the field is empty and disabled in Studio too — causing the wallet connection to fail on mobile.

Also concerning: the custom slug for this listing was empty in Studio even though I added one a couple of months ago and it currently appears to still work.

Hi there. For slugs, you no longer need to configure a fallback provider. We had a wallet connect issue that was just resolved and both listings should work without a fallback provider now. Can you confirm on your end?

Hi wilkins.eth — using Rainbow on iOS, I’m seeing the same error screen as before.

I tried both variations of the URL — manifold.gallery and gallery.manifold.xyz — including with a referrer I hadn’t previously tried.

The text in the address bar is pasted lower down.



I just tried rainbow + walletconnect on iOS, and metamask native browser and everything loads as expected. See screenshots:

Have you tried clearing your mobile browser cache? Also walletconnect itself can be flaky sometimes and there’s a few bug reports about mobile connectivity on walletconnect’s repo itself.

Thanks wilkins.eth — good to know things are working in those places on your end.

I should’ve been more specific: The Rainbow app recently has an in-app browser, and I’m seeing the issue in the in-app browser.

I’m able to connect with Rainbow via mobile Safari.

I’m also able to connect with Metamask, but seeing as they appear to throw an error message for artworks that include iframes, and then don’t display the artwork, I can’t recommend it to collectors.

Clearing local storage in the Rainbow app didn’t resolve the in-app issue of not being able to connect with a normal URL or referral URL.

Are you using walletconnect?

Does gallery.manifold.xyz/coda work?

I’m using walletconnect in Rainbow’s in-app browser, and am still unable to connect.

In the screenrecording, I tap:

  1. connect wallet
  2. wallet connect
  3. rainbow (read instructions to tap metamask in this context)
  4. got it
  5. connect wallet
  6. wallet connect
  7. metamask (read something went wrong)

Oh. I see what’s going on here (kind of). Rainbow browser does not work with Wallet Connect. When they say to “go back and choose metamask”, they mean to use another connection method rather than wallet connect. However we aren’t showing that method because we can’t detect their injected provider for whatever reason.

We’ll try and ping Rainbow to see what’s going on, but unfortunately we have no visibility into their mobile browser.

Hey there. Looks like the rainbow wallet connection issue is resolved now!