Manually updating Metadata for ERC721 / Minted with Claim app

Hello Manifold Community,

I launched my first collection with Manifold Claim App. I realised afterwards that I cannot update metadata for each token on the dapp. Can you please help me since I need to reveal those tokens asap.

Link to the claim page: Pixel Hollywood

Link to ipfs: ipfs/QmXww8dRBJxUsHPungzTndH75ECXrZv6ghPSNJM58uCcqX/

Contract address:

Thank you.

This might be a helpful thread:

I have already followed the entire on that thread and it didn’t work, i received the error on this TX:

I don’t know what im doing wrong.

The error is " ‘Cannot change payment token’" on the TX.

i dont know what to do, is not possible for you to update the metadata manually?

Now i got another error, solved the payment issue.

But now it says… " ‘Wallet is not an administrator for contract’"

Follow this specific post:

You want to use the updateTokenURIParams function.

You are likely calling the wrong function if you are getting a payment warning.

If you are getting the ‘wallet is not an administrator for the contract’ it means that you are not connected with the same wallet you deployed your contract with.

Hi wilkins, im connected with the same wallet i deployed the contract. I can asure that, its the only wallet i use.

I followed everything, and get into that error “Wallet is not an adminsitrator for the contract” , i already disconnected everything and tried again, but same error, anything else i can try?

Share screenshot of the etherscan things you are entering which also shows the connected wallet on etherscan, and provide the contract address and the wallet address.

We can’t help you unless more information is provided.

1 Like

Now the TX went through, but the metadata didn’t change.

Here’s the screenshots

Here’s the link to the metadata: ipfs/QmP1TJ3KnqXB3EFnAp3Vkh1LAw1AiSi1iZLJ7xZboHQHT6/

Here’s the TX:

Please provide a link to the nft.

Claim page: Pixel Hollywood


Update appears successful, and shows on chain as such. Not sure why OpenSea hasn’t refreshed yet.

Oh, I see a problem, your update was incorrect, you have an extra slash!

your location needs to remove the slash at the end. Then it will work.

1 Like

Actually, there are other issues. Your IPFS directory has the wrong data. You only have the images there. You need to actually upload the json metadata at those paths.

That’s why OpenSea isn’t updating the metadata. It’s wrong

Your IPFS is:
(note, you shouldn’t have the remaining slash)

This will result in:

However, that should point to the metadata file, not the image. Right now it points to the image.

Crap, how do i fix this? i mean , i didn’t generate a JSON manually before, was all made by manifold.

Yes, so you’ll have to generate it now yourself if you need unique assets.

Here’s what it originally was:

{"created_by":"Rodro","name":"Pixel Hollywood #1/100","external_url":"","description":"The 100 most iconic characters from Movies & Series hand-drawed by me!","attributes":[{"trait_type":"Artist","value":"Rodro"}],"image_details":{"bytes":2364964,"format":"GIF","sha256":"bc2bf4b21950009f7f0cf16a8365207d11119457b18c1128db93558ebd24215b","width":500,"height":500},"image":"","image_url":""}

You need to make one of these files for each NFT named 1, 2, 3…

And replace the name, image and image_url with what it should be. Then upload that to IPFS. Once you’ve done this, send me the IPFS link and I can double check for you before you write another transaction.

1 Like


Close, but not quite.

  1. The file names need to be 1, 2, 3… (not ending in .json)
  2. The image links should be pointing to your former IPFS link locations. Right now they link to ibb which doesn’t serve the actual jpg.
1 Like

Just checking in here, do you have an update?